Downloading Ruby Error

I typed this into the terminal: rvm install 1.9.3 and I got this error in return:

Error running ' ./configure --prefix=/Users/ppreyer/.rvm/rubies/ruby-1.9.3-p194 
--enable-shared --disable-install-doc --with-libyaml 
--with-opt-dir=/Users/ppreyer/.rvm/usr ', 
please read /Users/ppreyer/.rvm/log/ruby-1.9.3-p194/configure.log
There has been an error while running configure. Halting the installation.

I was wondering if anybody knew the best way to fix this error?

Answers


If you are setting a new machine and seems you are new to rvm, I suggest you to replace it with rbenv + ruby-build.

You will need to install homebrew that's a great tool for installing things really easily and it provides a tool that recommends you some configuration, just doing brew doctor, for example it says that you should install xcode command line tool, so you don't have this kind of problems.

It's lighter than rvm, and not obtrusive like rvm is, and it comes with auto-completion for your commands ;) It's really nice and I'm liking it away better than rvm.


I had a similar problem but found a working answer here: https://stackoverflow.com/a/14467463/1536309

rvm get head
rvm requirements run

It might ask you for your password.

After that run:

rvm install 1.9.3 --with-opt-dir=`brew --prefix readline` --without-tcl --without-tk

Can you share whats in your /Users/ppreyer/.rvm/log/ruby-1.9.3-p194/configure.log file? My best bet would a problem with clang try this

rvm install 1.9.3 --with-gcc=clang

Need Your Help

wxpython: Updating a dict or other appropriate data type from wx.lib.sheet.CSheet object

python wxpython spreadsheet wxwidgets

If I have a notebook with three spreadsheet widgets, what is the best way to have changes to the spreadsheet update a dictionary (or maybe an sqlite file?). Do all wx grid objects come with a buil...

Nice Label Algorithm for Charts with minimum ticks

java algorithm math charts

I need to calculate the Ticklabels and the Tickrange for charts manually.