To avoid Qt Creator from source mistakes the version of Qt upon building

I got the following error when I try building Qt Creator from source.

user@host:/usr/share/qtcreator/qtcreator_build$ qmake -version
QMake version 2.01a
Using Qt version 4.8.2 in /usr/local/Trolltech/Qt-4.8.2/lib
user@host:/usr/share/qtcreator/qtcreator_build$ sudo qmake ../qtcreator_fromSrc/qtcreator.pro 
Project MESSAGE: Cannot build Qt Creator with Qt version 4.6.2.
Project ERROR: Use at least Qt 4.7.4.

As shown, the Qt library in use above is 4.8.2, which should be qualifying ver 4.7.2. It's installed from source. How can I let the qtcreator installer recognize the right qt version?

Answers


My workaround was to copy the source of Qt Creator to the area that doesn't require super user permission. HTH.


Need Your Help

64 bit and 32 bit tools run in one environment

c++ oracle build dynamic-linking dynamic-loading

I have a script (bash) which calls 6 tools, 4 of them 32 bit compiled and 2 of them 64 bit compiled. one 32 bit and one 64 bit are oracle dependent tools. As Oracle dependent tools are dependent on

Plot multiple lines (data series) each with unique color in R

r colors plot unique lines

I am fairly new to R and I have the following queries :