Code Sign Error : Distribution iphone App

I have an iOS project to open and when i open it i get an error -

Code Sign error: The identity 'iPhone Distribution: x' doesn't match any valid, non-expired certificate/private key pair in the default keychain

What i have now is a file named given to me by the project owner-

CertificateSigningRequest.certSigningRequest

But i dont know what to do wit it. I created a CA and all that but i cant get it to work. Can anyone point me in the right direction?

Answers


Ok so here are detailed steps on how to distribute. You seem new to the topic:

  1. You want to request a development and distribution certificate in Keychain Access (I see you have done that) and upload it to developer.apple.com (you are part of the developer member program right?)

  2. Create an app ID (in provisioning profiles)

  3. Create a distribution certificate - make sure this and step 2 follow your bundle ID

  4. Download the profile and drag to Xcode

  5. Go to your Xcode project, in the target or project build settings set your code signing option to the Distribution certificate (which must match your Bundle ID and of course your distribution and development certificate)

  6. Now go to edit scheme -> then change from debug to release

  7. Set to build for an iOS device (or none at all)

  8. Go to product -> Build For -> Build For Archive

  9. Scroll down on the side (your classes tab etc.) to the product which should be named (AppName.app) and show it in finder.

    Create an application on iTunes Connect

    Compress the .app and load it to Application Loader

    Send it off!


You need to public and private key for the provisioning profile you are using. The person how created the certificate with which the provisioning profile is signed will have to supply you with them.


Need Your Help

How to write data into a JSON file using jquery

javascript jquery json html5

Am making an hybrid mobile app and i need to store some of the data like for example if its a game : the high score etc ..

How do I upgrade my npm installation?

node.js npm npm-install

I've been unable to upgrade my npm installation.