Maven and Eclipse: project build error dependency

I just started working with Maven, and I've ran into several issues. The latest is that one:

Project build error: 'dependencies.dependency.version' for com.github.koraktor:steamcondenser:jar is missing.

I'm running eclipse for Java Developers, with m2eclipse plugin, on Windows 7 x64. What I'm trying to do is install this API into my project:

https://github.com/koraktor/steam-condenser-java

I have been googling for the last hour with no success. What am I supposed to do? I tried adding the dependency from both the eclipse plugin and the pom.xml itself, but it didn't help.

EDIT:

Thanks everyone, as you said, all I had to do was including the version in the pom.xml.

Answers


Maven needs a "version" specifier in the dependency.

I use http://mvnrepository.com a lot to get the real Maven code for a given project. In this case, it's at: http://mvnrepository.com/artifact/com.github.koraktor/steam-condenser/1.2.0.

Here's their version of the dependency:

<dependency>
    <groupId>com.github.koraktor</groupId>
    <artifactId>steam-condenser</artifactId>
    <version>1.2.0</version>
</dependency>

Need Your Help

Youtube API - Use "this" to play the current video

javascript jquery css3 youtube-api

I'm using the youtube API and I want to play the current video that is clicked and stop it too but my problem is that I'm using the same ID for each video and I want to use the selector "this" to p...