ffmpeg 10.04 Could Not Find Codec Parameters

I am getting an error while executing the command ffmpeg -i /path/to/video.mp4 :

  ffmpeg version git-2012-07-24-93342de Copyright (c) 2000-2012 the FFmpeg developers
      built on Jul 24 2012 23:55:41 with gcc 4.4.3 (Ubuntu 4.4.3-4ubuntu5.1)
      configuration: --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-swscale --enable-vdpau --enable-version3 --enable-libtheora --enable-libvorbis --enable-libvpx --enable-x11grab
      libavutil      51. 65.100 / 51. 65.100
      libavcodec     54. 44.100 / 54. 44.100
      libavformat    54. 20.100 / 54. 20.100
      libavdevice    54.  2.100 / 54.  2.100
      libavfilter     3.  3.100 /  3.  3.100
      libswscale      2.  1.100 /  2.  1.100
      libswresample   0. 15.100 /  0. 15.100
      libpostproc    52.  0.100 / 52.  0.100
    [mov,mp4,m4a,3gp,3g2,mj2 @ 0x2a1b240] Could not find codec parameters for stream 0 (Video: h264 (avc1 / 0x31637661), 1280x720): unspecified pixel format
    Consider increasing the value for the 'analyzeduration' and 'probesize' options
    /path/to/video.mp4: could not find codec parameters

Answers


Adjust -probesize and/or -analyzeduration.

The files I was testing were in fact damaged. But if anyone faces this problem, setting -probesize and -analyzeduration to 100 and 10000000 for example might help.

From a popular comment by @DiverseAndRemote.com

my solution was ffmpeg -analyzeduration 2147483647 -probesize 2147483647 -i /path/to/video.mp4. 2147483647 is max_int


Need Your Help

How do I make a simple dot "." in HAML?

ruby-on-rails haml

In my Ruby on Rails Project I use HAML, I need to translate something like this

npm doesn't work, get always this error -> Error: Cannot find module 'are-we-there-yet'

node.js macos installation npm

i tried to install grunt on a mac with Yosemite. node is already installed in the newest version. if i type "node -v" in the terminal i get the line v0.12.5. thats good. but when i want to install