Integrating Facebook with iOS

I get all these errors and about 18 more when i try to integrate facebook to my application.

Undefined symbols for architecture i386:
"_ACAccountTypeIdentifierFacebook", referenced from:
  +[FBSession renewSystemAuthorization] in FacebookSDK(FBSession.o)
"_ACFacebookAppIdKey", referenced from:
  -[FBSession authorizeUsingSystemAccountStore:accountType:permissions:defaultAudience:isReauthorize:] in FacebookSDK(FBSession.o)
"_ACFacebookAudienceEveryone", referenced from:
  -[FBSession authorizeUsingSystemAccountStore:accountType:permissions:defaultAudience:isReauthorize:] in FacebookSDK(FBSession.o)
"_ACFacebookAudienceFriends", referenced from:
  -[FBSession authorizeUsingSystemAccountStore:accountType:permissions:defaultAudience:isReauthorize:] in FacebookSDK(FBSession.o)
"_ACFacebookAudienceKey", referenced from:
  -[FBSession authorizeUsingSystemAccountStore:accountType:permissions:defaultAudience:isReauthorize:] in FacebookSDK(FBSession.o)
"_ACFacebookAudienceOnlyMe", referenced from:
  -[FBSession authorizeUsingSystemAccountStore:accountType:permissions:defaultAudience:isReauthorize:] in FacebookSDK(FBSession.o)
"_ACFacebookPermissionsKey", referenced from:

Im using the latest facebook instructions on how to add facebook to my page but i am working with iOS 4.3 and above. SO it needs to cater to 4.3. I have set Accounts.framework to optional. Any one knows what these erros mean? Ive also tried adding any other implementation files that are not linked.

The errors are generated everytime i access FBSession or FBConnect etc.

Answers


For the record: we expect you to use XCode 4.5 for developing with the Facebook SDK 3.1 as described here

Account.framework, Social.framework and AdSupport.framework are all required (as described here) but use the 'optional' flag if you want to build for older iOS versions too.

Good luck.


With Account.framework you also have to add Social.framework and AdSupport.framework.


If you drag and drop Adsuport, Accounts or Social libraries from another project and you select "Copy items into destination group's folder" AdSuport and Social directories will be created into yours app source folder and you will get this linker error, remove directories and add libraries from project's Buld Phases -> Link Binary, you may also need to add libsqlite3.dylib


I think the Accounts.framework needs to be required. But it is only implemented in iOS 5 and later see developer reference for more information.


Solved this by upgrading to xcode 4.5.1 and then adding the social and adsupport framework and also the -lsqlitee3 or so as stated. I did add lsqlite3 before but it said multiple values on top so i just took the unnecessary for base sdk comments out and it worked.


Need Your Help

How to get the request parameters in symfony2

php symfony

I am very new to symfony. In other languages like java and others I can use request.getParameter('parmeter name') to get the value.