Azure Websites DNS

I have an azure website at yis3.azurewebsites.net - I have promoted this to be a "shared" site so that I can use a custom domain. I have the domain yorkshireimagescanning.co.uk that I bought from 123-reg.co.uk. I have configured this to give a CName record with dnsname of "awverify" and destination of awverify.yis3.azurewebsites.net.

I've waited over 12 hours and checked on digwebinterface.com and all looks good but when I click to "Manage custom domains" from the Azure portal , I enter a domain name of "yorkshireimagescanning.co.uk" but it won't accept it.

Please help

* Edit * I've now waited a couple of days for domain propagation. Here's a screen grab from my domain registrar:

In the azure portal I've tried to add the following custom domains for the yis3.azurewebsites.net site but it won't accept any:

  • awverify.www.yorkshireimagescanning.co.uk www.yorkshireimagescanning.co.uk yorkshireimagescanning.co.uk awverify.yorkshireimagescanning.co.uk

Here's a screen grab from the portal:

Answers


To use yorkshireimagescanning.co.uk

To use your domain without the www. prefix you need to add an A Record in addition to the CNAME you've added for "awverify".

First, make sure you've added the domain to the Azure portal by following the instructions under "Set the domain name in management portal" here.

Next, follow the instructions under "Configure an A record for the domain name" on the same page. This involves pointing your domain directly at the IP address of the Azure web site. You should then have added 2 DNS records in total:

CNAME    awverify.www     awverify.yis3.azurewebsites.net
A        xx.xx.xx.xx      (your website's IP address)

I've marked the next option as "preferred" because it points your domain at the Azure hostname "yis3.azurewebsites.net" instead of directly at the IP address. The IP address of your Azure website won't change, but if you ever need to deploy your website elsewhere it will have a different IP, so there will be a delay while the DNS change propagates.


To use www.yorkshireimagescanning.co.uk (preferred)

To use your domain with a www. prefix you need to add another CNAME record in addition to the one you've already added.

First, make sure you've added the domain to the Azure portal by following the instructions under "Set the domain name in management portal" here.

Next, follow the instructions under "Configure the CNAME on your domain registrar" on the same page. This involves adding a CNAME that points "www" to your Azure website's hostname (yis3.azurewebsites.net). You should then have added 2 DNS records in total:

CNAME    awverify.www     awverify.yis3.azurewebsites.net
CNAME    www              yis3.azurewebsites.net

A note about domain forwarding: Don't use 301 forwarding unless your site has been permanently moved. Use 302 for temporary redirection. More details here.


I finally figured out what was wrong. I was deploying a new version of an existing site but the old version still had www.yorkshireimagescanning.co.uk set on the custom domains page. Once I deleted it then I was able to add the domain on the new azure site.


Need Your Help

How can I display an image from a file server with HTML

html image server display

I have a website that displays a lot of messages and images, usually through normal HTML tags. We now have a file server where we would like it to be our one stop place to retrieve files and imag...

Error while setting history server in hadoop

hadoop mapreduce yarn bigdata

All the datanodes are UP and running,however still getting following error while setting up history server(mapreduce2) in hadoop.