installing usbmuxd under Mac OS X

I installed the latest version of libusb and now I'm trying to install usbmuxd.

However, it gives this error:

configure: error: Package requirements (libusb-1.0 >= 1.0.3) were not met:

No package 'libusb-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

In the installation log of libusb it says

libtool: install: /usr/bin/install -c .libs/libusb-1.0.0.dylib /usr/local/lib/libusb-1.0.0.dylib

It looks like the wrong version of the library is getting installed.

How can I solve this?

Answers


You should consider installing macports, which has usbmuxd v1.0.7 available, and then:

$ sudo port selfupdate
$ sudo port install usbmuxd

(you should de-install the libusb package you installed yourself, before doing this probably).


Need Your Help

Is the Rails default CSRF protection insecure?

ruby-on-rails security xss csrf

By default the form post CSRF protection in Rails creates an authenticity token for a user that only changes when the user's session changes. One of our customers did a security audit of our site and