setting customView in actionBar

I'm writing a view for styling my application's ActionBar,while it works perfectly in portrait,in landscape it clips the a line which is anchored to the bottom? Is it because ActionBar is assigned a certain height and my custom view is bigger than this? here's the XML for my custom view:

<?xml version="1.0" encoding="utf-8"?>
<RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
android:layout_width="match_parent"
android:layout_height="wrap_content"
android:orientation="vertical"
android:background="#252525" >

<ImageView
    android:id="@+id/imageView1"
    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:layout_alignParentRight="true"
    android:layout_alignParentTop="true"
    android:src="@drawable/ac_logo" />

<LinearLayout
    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android:layout_alignParentLeft="true"
    android:layout_below="@+id/imageView1" >

    <LinearLayout
        android:layout_width="wrap_content"
        android:layout_height="2dp"
        android:layout_weight="1"
        android:background="#F0C46C" >
    </LinearLayout>

    <LinearLayout
        android:layout_width="wrap_content"
        android:layout_height="2dp"
        android:layout_weight="1"
        android:background="#FFFFFF" >
    </LinearLayout>
</LinearLayout>

<ImageView
    android:id="@+id/imageView2"
    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:layout_alignParentTop="true"
    android:layout_centerHorizontal="true"
    android:scaleType="fitXY"
    android:src="@drawable/ac_text" />

Answers


ok I figured it out, I'll post it just in case it helps anyones that happens to see this :)

<?xml version="1.0" encoding="utf-8"?><RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
android:id="@+id/parent"
android:layout_width="match_parent"
android:layout_height="wrap_content"
android:orientation="vertical"
android:background="#252525" >

<ImageView
    android:id="@+id/imageView1"
    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:layout_alignParentRight="true"
    android:layout_alignParentBottom="true"
    android:src="@drawable/ac_logo" />


<ImageView
    android:id="@+id/imageView2"
    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:layout_centerVertical="true"
    android:layout_centerHorizontal="true"
    android:scaleType="fitXY"
    android:src="@drawable/ac_text" />

<LinearLayout
    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android:layout_alignBottom="@+id/imageView1">

    <LinearLayout
        android:layout_width="wrap_content"
        android:layout_height="2dp"
        android:layout_weight="1"
        android:background="#F0C46C" >
    </LinearLayout>

    <LinearLayout
        android:layout_width="wrap_content"
        android:layout_height="2dp"
        android:layout_weight="1"
        android:background="#FFFFFF" >
    </LinearLayout>

</LinearLayout>


Need Your Help

Swift NSUserDefault for TableView with Multiple Sections?

ios swift uitableview nsuserdefaults

I'm currently doing an Xcode Project (SWIFT) and I have a few problems relate to NSUserdefault and prepareforsegue.

G++ and sed pipeline

bash sed g++

I would like to replace all "no" by "on" in the console output of g++. I tried