Can not install java7 to ubuntu 12.10

I want to install java7 to ubuntu 12.10. But I can not install. I had called to following code:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update

They is successful.Then:

sudo apt-get install oracle-java7-installer

It is unsuccessful. Error is given:

sudo apt-get install oracle-java7-installer
dagli@dagli-Inspiron-N5110:~$ sudo apt-get install oracle-java7-installer
[sudo] password for dagli: 
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı inşa ediliyor.       
Durum bilgisi okunuyor... Bitti       
oracle-java7-installer zaten en yeni sürümde.
Sıralanan paketler otomatik olarak kurulmuştu artık gerekli değiller:
psensor-common
Use 'apt-get autoremove' to remove it.
Yükseltilen: 0, Yeni Kurulan: 0, Kaldırılacak: 0 ve Yükseltilmeyecek: 221.
1 tam olarak kurulmadı veya kaldırılmadı.
Bu işlemden sonra 0 B ek disk alanı kullanılacak.
Devam etmek istiyor musunuz [E/h]? E
oracle-java7-installer (7u10-0~webupd8~0) kuruluyor...
/var/lib/dpkg/info/oracle-java7-installer.postinst: 89: [: unexpected operator
Removing outdated cached downloads...
Downloading Oracle Java 7...
--2013-01-12 19:20:58--  http://download.oracle.com/otn-pub/java/jdk/7u10-b18/jdk-
7u10-linux-x64.tar.gz
download.oracle.com (download.oracle.com) çözümleniyor... 23.63.99.147, 23.63.99.106
download.oracle.com (download.oracle.com)[23.63.99.147]:80 bağlanılıyor... bağlantı    
 kuruldu.

HTTP isteği gönderildi, cevap bekleniyor... 302 Moved Temporarily Yer: https://edelivery.oracle.com/otn-pub/java/jdk/7u10-b18/jdk-7u10-linux-x64.tar.gz [izleyen] --2013-01-12 19:20:58-- https://edelivery.oracle.com/otn-pub/java/jdk/7u10-b18/jdk-7u10-linux-x64.tar.gz edelivery.oracle.com (edelivery.oracle.com) çözümleniyor... 2.22.26.174 edelivery.oracle.com (edelivery.oracle.com)[2.22.26.174]:443 bağlanılıyor... bağlantı kuruldu. HATA: cannot verify edelivery.oracle.com's certificate, issued by /C=US/O=Akamai Technologies Inc/CN=Akamai Subordinate CA 3': Unable to locally verify the issuer's authority. edelivery.oracle.com adresine güvenliği gözardı ederek bağlanmak için--no-check-certificate' seçeneğini kullanın. download failed Oracle JDK 7 is NOT installed. dpkg: error processing oracle-java7-installer (--configure): installed post-installation script alt işlemi çıkış durumunda hata döndürdü : 1 Apport raporu yazılmadı çünkü zaten en yüksek rapor sayısına ulaşıldı İşlem sırasında hatalar bulundu: oracle-java7-installer E: Sub-process /usr/bin/dpkg returned an error code (1) dagli@dagli-Inspiron-N5110:~$

Answers


There is a way to install jdk7 on Ubuntu 12.10 in this page http://www.upubuntu.com/2012/10/how-to-install-oracle-java-7-jre-7-jdk.html

I tried to install and I have installed correctly.


Take a look here Unixmen.com

Or if you prefer:

sudo add-apt-repository ppa:webupd8team/java

sudo apt-get update

sudo apt-get install oracle-java7-installer

That's all.


It did not work for me too. It seems, that the download url of the oracle java package is changed, or they require to log in for the download.

This is how I have solved the problem:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer

This gives "302 Moved Temporarily" and "sha256sum mismatch jdk-7u51-linux-x64.tar.gz" error, so download the package manually from here (you need to log in): http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html and overwrite with the downloaded file in this directory /var/cache/oracle-jdk6-installer

Then repeat the last command again, and now it will work:

sudo apt-get install oracle-java7-installer

This is an old post, but in case you stumble over this problem currently you are probably running into the problem that you're not on one of the LTS releases.

If you go to https://launchpad.net/~webupd8team/+archive/java/+packages you'll see for which series these packages are published, atm it's:

  • Lucid (10.04)
  • Precise (12.04)
  • Saucy (13.10)
  • Trusty (14.04)
  • Utopic (14.10)

for the oracle-java7-installer - 7u55-0~webupd8~1

Now check with

lsb_release -a

which version you're on. For me it was raring (13.04) and as you can see above it's not published for this any more. So after the

sudo add-apt-repository ppa:webupd8team/java

I went to /etc/apt/sources.list.d/webupd8team-java-raring.list and /etc/apt/sources.list.d/webupd8team-java-raring.list.save and changed the raring to saucy, so the entries look like

deb http://ppa.launchpad.net/webupd8team/java/ubuntu saucy main

I then ran

sudo apt-get update

and after that I could install the package

sudo apt-get install oracle-java7-installer

Need Your Help

Droppable creates (un)nested object - But the position of draggable changes

jquery jquery-ui jquery-ui-draggable jquery-ui-droppable

I am dragging an object inside a droppable that is also a draggable. After I drop the object, it is nested inside the droppable. Similarly if I drag the object outside droppable, it is not nested a...

Custom Wordpress index.php which circumvents The Loop isn't working correctly

php wordpress wordpress-theming

I'm building a Wordpress theme for a client and it's unlike any other theme I've built before in that the homepage is a collection of posts spread across multiple different containers and styles. I...