Fiddler 2 Wipes My Internet Explorer Proxy Settings

I just started using Fiddler 2 to create request objects for REST,JSON, and SOAP based services that I have been creating. It has worked great so far.

The problem came when I attempted to use some of my company resources through Internet Explorer. I was getting some sort of a DNS error, which I realized was happening because my proxy settings were getting wiped every time I open fiddler (IE6 and IE8). Does anyone know what Fiddler might be "fiddling" with here that would cause such a strange problem.

More info: This is happening on an Virtual PC VM running Windows XP. The exact stuff that is being blanked resides in the Tools->Internet Options->Connections->LAN Settings window. Both checkboxes there were checked and the fields in the Advanced window were populated. Afterwards, all were blanked.

Answers


Fiddler changes your proxy settings on startup and reverts them back to what they were before you started when Fiddler is closed.

However, that doesn't really explain your problem, because when Fiddler is running it will use your old proxy server as an upstream proxy, and when you shut it down, it reverts the settings back to what they were before.

If you don't want to use Fiddler with IE, uncheck the "Act as system proxy" checkbox inside Tools / Fiddler Options; note that you'll need to manually configure your application or framework (e.g. .NET) to use 127.0.0.1:8888 as a proxy though.


1.) Open a command prompt with Administrator priveleges

2.) Type NETSTAT -AB

3.) See if anything is running on Port 8888 already

If so, that is your problem. Change Fiddler to run off port 8889 (or next available port)

1.) Tools -> Fiddler Options -> Connections -> Fiddler listens on port -> 8889


It's getting blanked out because Fiddler works by adding itself as a proxy instead of using your current proxy settings. That's how it intercepts all the traffic.

The good news is that, with a little configuration, you can configure Fiddler to act as a proxy AND use your manually configured corporate proxy as well:

Fiddler Web Debugger - Configuring Clients


Fiddler killed my ie connection but firefox connection remained....

I had an error "Fiddler: DNS Lookup for wwww.google.com.au failed. No such host is known"

I just fixed mine. I put "http://localhost:8888/VirtFolder/MyWebApp" into the url and it seemed to make the connection and IE start to work again.


Make sure your proxy is not pointing to a .PAC file. Fiddler does not "keep" this configuration when launched. Instead, type the actual proxy FQDN manually.


Need Your Help

GNUPLOT Each Histogram Bar with different color

bitmap gnuplot histogram

I want to visualize the amount of different colors of a bitmap file.

Get my wifi ip address Android

android ip android-wifi android-networking

How can I get the ip address of my phone when it is connected under wifi?