WebSphere Application Server 6.1 support for Java 1.6?

Can I use Java 1.6 with WebSphere Application Server 6.1? IBM's website says no.

But I require Java 1.6 for a software application to be deployed and I cannot currently upgrade to Websphere 7.0, or use a different application server (WAS 6.1 is the org standard).

what are my options?

Thanks.

Answers


Nobody can stop you from trying to run WAS 6.1 with Java 6 but this configuration IS NOT SUPPORTED by IBM and according to this thread, I'm not even sure you'll be able to start WAS.


Since websphere 6.1 does not support J2SE 6, your options are very limited.

option 1

  • Talk to your upper management & convince them the need to switch to WAS 7.0

option 2

  • Downgrade your code compatibility to 1.5 and compile for J2SE 5.0

option 3

  • If you have a support contract with IBM, open a high priority ticket for getting 1.6 support on WAS 6.1

Need Your Help

When do we use MVVM?

c# wpf design-patterns mvvm

I have been hearing a lot of hype about MVVM for WPF. When do we use it? Is it a use for everything or does it only have specific uses? Is it worth it for every project?

SQL- JOIN two column from two tables

mysql sql database union

I need help to formulate a query. I want to select all DISTINCT colors from TABLE A and TABLE B.