How to solve IIS issue in visual studio?

I attempted to run my web service through visual studio. I faced an issue like :

---------------------------
Microsoft Visual Studio
---------------------------
Unable to launch the IIS Express Web server.

Failed to register URL "http://localhost:63591/" for site "xxxxxx" application
"/". Error description: The process cannot access the file because it is being
used by another process. (0x80070020)

---------------------------
OK   
---------------------------

I saw the task manager and found that PID 4 is used by System and its Description is NT Kernel & System. So I tried to stop the http service. All dependency services stopped. But I am facing an issue in stopping http service like

The service is starting or stopping.  Please try again later.

So, I tried to stop and start the service manually. But the End process is disabled. It will be helpful if anyone could help with this issue

Answers


From https://www.davidsalter.co.uk/unable-to-launch-the-iis-express-web-server-error-0x80070020/

Error code 0x80070020 means ERROR_SHARING_VIOLATION, which in the case of IIS Express (or IIS) means that the port that it is attempting to listen on is being used by another process.

Use the netstat command to find out which application is using the port.

netstat -ao | findstr <port_number_to_search_for>

The a parameter tells netstat to display all connections and listening ports.

The o parameter tells netstat to display the process ID associated with the connection.

Running the above netstat command will produce output such as:

C:\>netstat -ao | findstr 4026
TCP    12.0.0.1:4026        cs-pc:4026         LISTENING       9544

The last number displayed (9544 here) is the process ID.


I had the same problem. I just restarted Visual Studio and it worked.


I had the same Issue. As @Kautsky Lozano mentions above Another application is using that port.

So [for a Windows OS] just:

  • Open Resource Monitor (Task Manager -> Performance -> Open Resource Monitor )
  • Click on the Network tab.
  • And at TCP Connections find the application that uses the Local Port that IIS Express uses and close it. (it was firefox on my case)

I ran into the same problem after we had upgraded a solution from Visual Studio 2012 to 2015. I had come here and ran netstat only to find that no other application was using the same ports. It turns out I had the same sites with the same ports mapped in the applicationhost.config at Users/<username>/Documents/IISExpress/config and the applicationhost.config in the .vs folder inside my solution. I should note that the problem didn't start right after the upgrade either. It just start failing consistently one morning. A couple reboots didn't seem to solve the problem either.

Removing the conflicted sites from the one stored in my Documents and restarting Visual Studio solved the problem.


Another application is using that port. This could help you


I had this problem when upgrading an MVC project. I copied over the newer-MVC .csproj over my existing .csproj file then worked back to a fully working Project. What I failed to consider is the existing port number in the old .csproj. The new project had a new port number, yet shared the Project/Assembly Name. That was enough to make IIS Express lose its mind and throw this exception.

Just digging the old port number out of git and changing the IIS Express URL to include it in Project Settings was enough to fix it.


The easiest first pass at this without getting into the command console is to just shut down all applications (including VS), then launch VS by itself and try it again. There is likely another application like your browser causing the conflict. In my case Chrome caused it and was solved when shutting everything down and restarting VS. I opened Chrome again and everything was fine.

The netstat stuff above is useful, but to me that's only if you can't do what I'm suggesting.


to summarize all the answers. There are 2 solutions. Both worked for me. - Solution #1 Kill the app that uses the same port. - Solution #2 Configure IIS Express to use a different port for your project.

Solution #1 (supposing the port in the error message was 443) Run in the command line:

netstat -ao | findstr 443

it returns: TCP 0.0.0.0:443 pe01:0 LISTENING 2904 The last number (thanks to @chris-schiffhauer) is PID to kill. Go to the Task Manager -> Processes -> [Show Processes From All users], Kill a process with PID=2904. In my case, it was VmWare host.

Solution #2 (Supposing message was: Failed to register URL "http://localhost:433/" for site "MyProject.Website0"...). Open the folloing file in notedpad++: C:\Users\MY_USER_NAME\Documents\IISExpress\config\applicationhost.config Find in it a line containing:

<site name="MyProject.Website0" id="...
...
            <bindings>
                <binding protocol="http" bindingInformation="*:80:localhost" />
                <binding protocol="https" bindingInformation="*:443:localhost" />
            </bindings>

Either change 433 to something else, like 4330 or delete the conflicting <binding.../> tag.


Go to Web Project Properties >> Web >> Project Url >> Change port i.e: http://localhost:22345/ => http://localhost:22346/ Hope this help!


I tried the following already:

  • Restarted Visual Studio
  • Check all available ports that might be listening to my specific number but it always return zero results. No processes is listening in my port.
  • I also tried using this but zero results.

    netstat -aon | find ":80"

  • I also tried using but also return zero results.

    netstat -ao | findstr

So what I did is delete this "Microsoft.VsHub.Server.HttpHostx64.exe" then my project successfully started and launch in browser. The error was fixed. I am not sure why but it works.

Here is the screenshot:


I was able fix this problem by removing everything from <site> to </site> tags in

Users/<username>/Documents/IISExpress/config/applicatiohost.config file

<sites>
  <site>
     .
     .   ===> remove this content including the <site> and </site> tags.
     .
  </site>
</sites>

Having just wasted half a day trying to fix this same issue, I felt I should add the solution which eventually worked for me.

TL;DR If netstatindicates that the problematic isn't in use, still try a few others in a totally different range

I've run into this problem before but usually find restarting visual studio, changing ports (increment by 1) or rebooting do the trick. However on this occasion none of this helped, and netstat wasn't finding a conflicting process. I even reinstalled IIS and visual studio and removed several other programs which I suspected could be interfering. It seemed as though IIS was trying to launch multiple instances of the same site.

Eventually I tried running netstat without findstr. I visually scanned the list of active ports and noticed that although the ones I had tried were not listed, there were a few processes using ports in a similar range. So instead I looked for a range which was free, picked a port number and that seems to now be working.

I'd love to hear if anybody can explain why this might have worked?


I just had this issue even though netstat did not show any conflicts.

The following fixed it for me:

  1. Close Visual Studio
  2. Open up File Explorer
  3. Navigate to the folder of the offending project
  4. Delete the obj and bin folders
  5. Delete the *.user file (this is probably optional)
  6. Restart Visual Studio and try again

Need Your Help

How to navigate in JSF? How to make URL reflect current page (and not previous one)

jsf url redirect navigation

I am currently learning JSF and was rather amazed and puzzled when I realized that whenever we use &lt;h:form&gt;, the standard behavior of JSF is to always show me the URL of the previous page in ...