Android Studio Gradle BuildTools Revision

I have an Android Project in Android Studio 0.5.9 and Gradle is throwing this error:

Error:The SDK Build Tools revision (17.0.0) is too low. Minimum required is 19.0.0

I have already installed SDK Build Tools Revision 19 from the SDK Manager and here is my build.gradle

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.10.+'
    }
}
apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 17
    buildToolsVersion "19.0.0"

    defaultConfig {
        minSdkVersion 9
        targetSdkVersion 17
    }

    sourceSets {
        main {
            manifest.srcFile 'Manantiales/src/main/AndroidManifest.xml'
        }
    }
}

How do I tell gradle to use the Build Tools 19 if it's already installed?

EDIT: I marked a different answer as The Best Answer because it was the one that worked for most people

Answers


I had the same problem this morning after updating to .6.0. You need to change you gradle version in /projectName/build.gradle

classpath 'com.android.tools.build:gradle:0.11.+'

Open your SDK manager and download the new version of the build tools 19.1 then change the following line in /projectName/moduleName/build.gradle

android {
  compileSdkVersion 19
  buildToolsVersion "19.1" //This version needs to be updated to 19.1 after SDK update

  ...

}

Then sync your gradle files and you should be good to go!


I didn't realize that my errors changed when I changed buildToolsVersion "19.0.0" to buildToolsVersion "19.1.0" in my build.gradle.

The first error was:

Error: The SDK Build Tools revision (19.0.0) is too low for project 'android'. Minimum required is 19.1.0

The second error was a little bit different, but I didn't see it:

Error: The SDK Build Tools revision (19.0.0) is too low for project ':CordovaLib'. Minimum required is 19.1.0

So I've also changed the build.gradle inside the CordovaLib folder, and the error disappeared.


I have just recently updated my android studio to 0.6.0, and it was giving me the same problem. But my build was 19.0.3, instead of 19.1.0. I changed the buildToolsVersion "19.0.3" to --> "19.1.0" which it forced the Gradle to download the updates. I restarted my Android Studio, and the error went away. Not sure exactly how to explain, but I think it forces it to download the patch off the Maven site, and does its justice behind scenes. And just as Gabriel Matusevich said, the build.gradle is located ProjectFolder -> AppFolder -> build.gradle

Exception: I havn't completed tested this out, but I did notice the Gradle was downloaded from the site, I havn't added or deleted code, or ran the application yet. So to be sure, remember the buildToolsVersion number you had before!


Open Android SDK Manager and make sure you have Build Tools 19.1 downloaded. Double-check.

Then find build/app.gradle and change buildToolsVersion number to '19.1':

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion '19.1'
    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 19

    }

I fixed this issue by going into myAppProject/actionbarsherlock/build.gradle and changing

android {
    compileSdkVersion 14
    buildToolsVersion '17.0.0'

to this

android {
    compileSdkVersion 14
    buildToolsVersion '19.1.0'

I found the problem, build.gradle was on the wrong folder


Hi for me after download the last version of the android SDK Tools, I change the android version F4 (Module Settings)

https://www.dropbox.com/s/9ypuepxfwlcp4e5/Captura%20de%20pantalla%202014-06-10%2000.45.38.png


I had the same problem. This is what me solved this problem.

Step 1: Go To SDK Manager

Step 2: Upgrade your Android sdk Build-Tool From current to updated version. (In my case am upgrade it to 21.1.2)

Step 3: Rebuild your application.

This Steps Solved My Problem. Hope it solves your problem too.


i fix the problem in this way:

Go to: projectFolder/gradle.proprieties

modify the ANDROID_BUILD_TOOLS_VERSION=19(or another version) to ANDROID_BUILD_TOOLS_VERSION=19.1


I too faced the same problem and the fix was so simple. Just launch android SDK manager and check the latest build tools. Finally click on install packages which were selected. Now restart the IDE and try building the project.


change in build.gradle "project: layout xml " code >>

 buildscript {
repositories {
    jcenter()
}
dependencies {
    classpath 'com.android.tools.build:gradle:2.2.3'


}

}allprojects { repositories { jcenter() enter code here } }


Need Your Help

How to have at least two datepickers of ui-bootstrap on a single page?

angularjs datepicker angular-ui-bootstrap

I want to have several datepickers on a page. But with the default solution from UI-Bootstrap it is not possible, no one of datepickers may be opened. The conflict with each other. Here is my code:...