Parser problem with Seam Test

I have a maven project in Eclipse, a web-project using Seam. Now I wanted to use Seam Test for unit test. I dit not use SeamGen to create the project.

I followed this guide, but when I run my test I get this error. I get a feeling the wrong sax parser is being used. Does anyone recognize it?

    [Parser] Running: :\Documents and Settings\PEJA715\Local Settings\Temp\testng-eclipse\testng-customsuite.xml 

FAILED CONFIGURATION: @BeforeSuite startSeam
java.lang.RuntimeException: Unable to bootstrap: 
    at org.jboss.embedded.Bootstrap.bootstrapURL(Bootstrap.java:147)
    at org.jboss.embedded.Bootstrap.bootstrap(Bootstrap.java:183)
    at org.jboss.embedded.Bootstrap.bootstrap(Bootstrap.java:195)
    at org.jboss.seam.mock.EmbeddedBootstrap.startAndDeployResources(EmbeddedBootstrap.java:11)
    at org.jboss.seam.mock.AbstractSeamTest.startJbossEmbeddedIfNecessary(AbstractSeamTest.java:1024)
    at org.jboss.seam.mock.AbstractSeamTest.startSeam(AbstractSeamTest.java:915)
    at org.jboss.seam.mock.SeamTest.startSeam(SeamTest.java:58)
Caused by: org.jboss.xb.binding.JBossXBRuntimeException: Failed to create a new SAX parser
    at org.jboss.xb.binding.UnmarshallerFactory$UnmarshallerFactoryImpl.newUnmarshaller(UnmarshallerFactory.java:100)
    at org.jboss.kernel.plugins.deployment.xml.BeanXMLDeployer.deploy(BeanXMLDeployer.java:85)
    at org.jboss.embedded.Bootstrap.deployBaseBootstrapUrl(Bootstrap.java:130)
    at org.jboss.embedded.Bootstrap.bootstrapURL(Bootstrap.java:142)
    ... 21 more
Caused by: org.jboss.xb.binding.JBossXBException: Failed to create a new SAX parser
    at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.(SaxJBossXBParser.java:97)
    at org.jboss.xb.binding.UnmarshallerImpl.(UnmarshallerImpl.java:55)
    at org.jboss.xb.binding.UnmarshallerFactory$UnmarshallerFactoryImpl.newUnmarshaller(UnmarshallerFactory.java:96)
    ... 24 more
Caused by: javax.xml.parsers.ParserConfigurationException: Feature 'http://apache.org/xml/features/xinclude' is not recognized.
    at org.apache.xerces.jaxp.SAXParserFactoryImpl.newSAXParser(Unknown Source)
    at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.(SaxJBossXBParser.java:92)
    ... 26 more
... Removed 15 stack frames
SKIPPED CONFIGURATION: @BeforeClass setupClass
SKIPPED CONFIGURATION: @BeforeMethod begin
SKIPPED CONFIGURATION: @AfterMethod end
SKIPPED CONFIGURATION: @AfterClass cleanupClass
SKIPPED: testRegister

===============================================
    TestOfTest
    Tests run: 1, Failures: 0, Skips: 1
    Configuration Failures: 1, Skips: 4
===============================================


===============================================
effsort-web
Total tests run: 1, Failures: 0, Skips: 1
Configuration Failures: 1, Skips: 5
===============================================

[org.testng.internal.PoolService] Shutting down poolservice org.testng.internal.PoolService@1117a20 terminated:false

Answers


Hard to say from the stacktrace (showing your dependencies might help) but double check that you use the SAX parser used by JBoss 5.0.1.GA (and not xml-apis that you might get transitively).


Need Your Help

Get connectivity status on a blackberry 10 Dev Alpha Simulator

blackberry-simulator blackberry-10 connectivity

I am developing an app for BB10 which requires to identify whether the device is connected to Internet or not.

Disable puts output in RSpec

ruby rspec progress-bar output stdout

I got a ProgressBar with some logs, and it is being displayed on each iteration. When I run RSpec, I'd like that only the results to get displayed (only . or f, and not the output that my app may