QT app i made exited with code -1073741515

I have coded a program in QTcreator on linux and when i tried to port it to windows. Program compiles without any errors. But when i run the program it exits automatically Starting C:\Projects\LIG\debug\LIGenerator.exe...

C:\Projects\LIG\debug\LIGenerator.exe exited with code -1073741515

I tried to debug it using QT creator debugger. But flow of the program does not pass even through main.cpp

how to debug the program and fine where is the errors.


Update

In the .pro file the INCLUDEPATH and LIB are the following

win32:INCLUDEPATH += "C:\Program Files\Expat 2.0.1\Source\lib"
win32:INCLUDEPATH += "E:\confuse-2.7\confuse-2.7\src"
win32:INCLUDEPATH += "C:\Projects\LithologyInputGenerator5\XML"
win32:LIBS += -L"C:/Program Files/Expat 2.0.1/Bin" \
    -L"C:/Program Files/GnuWin32/lib/" \
    -L"E:/confuse-2.7/confuse-2.7/windows/msvs.net/libConfuse/Release" 
LIBS += -lexpat \
    -lcrypto \
    -lssl\
    -lconfuse
unix:LIBS += libgsoap++.a \
    -lgsoap
win32:LIBS += -lwsock32

Update

I have used dependency walker as mentioned which help me to find the missing dependencies. I have now fixed all the dependencies except MPR.DLL ( Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.). IT was not missing so i left it out. Also i have used a configuration file. I have now copied the conf file to debug dir for WIN32 compiler.I don't remember whether i have used more than one conf file Still the program automatically exit with code -1073741515 . I tried to debug program using GUI debugger . But program is not even breaking at main also.

Could any one help me to get out of the this?

Answers


-1073741515 is the same as 0xC0000135 which I think often is because a a dependency is missing. I'd suggest checking that all DLLs your app depends on are in the correct locations.

You can use Dependency Walker for this.


I had the same problem, fixed by changing project settings Projects -> Tool chain -> MinGW (x86 32bit)


Need Your Help

Text Shadow in Internet Explorer?

css internet-explorer css3

I'm coding a webpage and here is how it looks in Firefox, Safari, Opera, and Chrome.

How Can I Connect Visual Studio 2008 to Team Foundation Service and Visual Studio Online?

visual-studio-2008 tfs azure-devops tfs2012 visual-studio-2008-sp1

I've made sure that I have all of the prerequisites covered, then tried to install the patch from here: