How can I install the M2E - Maven Integration in Eclipse?

I am attempting to install the plugin via the repository install in Eclipse ( Help -> Install New Software -> Work With: http://download.eclipse.org/technology/m2e/releases/ -> Next) and am getting a big error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: m2e - Maven Integration for Eclipse (includes Incubating components) 1.6.2.20150902-0002 (org.eclipse.m2e.feature.feature.group 1.6.2.20150902-0002)
  Missing requirement: Maven Integration for Eclipse 1.6.0.20150526-2032 (org.eclipse.m2e.core 1.6.0.20150526-2032) requires 'bundle org.eclipse.core.resources 3.9.0' but it could not be found
  Missing requirement: Maven Integration for Eclipse 1.6.1.20150625-2338 (org.eclipse.m2e.core 1.6.1.20150625-2338) requires 'bundle com.google.guava [14.0.1,16.0.0)' but it could not be found
  Missing requirement: Maven Integration for Eclipse 1.6.2.20150902-0002 (org.eclipse.m2e.core 1.6.2.20150902-0002) requires 'bundle com.google.guava [14.0.1,16.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: m2e Marketplace 1.6.2.20150902-0002 (org.eclipse.m2e.discovery 1.6.2.20150902-0002)
    To: bundle org.eclipse.m2e.core [1.6.0,1.7.0)
  Cannot satisfy dependency:
    From: m2e - Maven Integration for Eclipse (includes Incubating components) 1.6.2.20150902-0002 (org.eclipse.m2e.feature.feature.group 1.6.2.20150902-0002)
    To: org.eclipse.m2e.discovery [1.6.2.20150902-0002]

I tried finding information on the guava bundle but am not able to search for this in the Eclipse marketplace or find any repo out there I can install from either.

I am using Eclipse Juno SR2. I've read that certain version of Eclipse can't install guava bundle but didn't read that Juno was one of them.

Answers


Juno only supports 1.3 version. So download it from here.

download.eclipse.org/technology/m2e/releases/1.3


You're trying to install the latest version of m2e into a very old version of Eclipse; the two are not compatible. You have 2 options:

  1. Install a new version of Eclipse. The Java and Java EE packages both include m2e so you won't have to do anything to install it into them. Plus you get the benefit of having the latest features and bug fixes in both Eclipse and m2e.
  2. Install the version of m2e that's compatible with your Juno Eclipse release. To do so with the Install New Software... wizard, select the Juno repository to work with (not the m2e repository), and search for m2e in the list of options.

Need Your Help

How to reload the current view when I change the locale in app in android

android android-layout android-fragments locale android-location

I am currently work with changing language in the app. My app structure is tab host + fragment I have successfully change the locale but it is quite strange.

Destroying Null Session Variables

php html session

I have created session for my website.To have session started i have wrote following code on each link of website: