what is the appropraite version of zookeeper?

i'm new to storm ,zookeeper and java Now i imported project using storm -0.8.2 with recommended maven -3.X but i don't know what is the version of zookeeper and version of maven that i should install it !!?

and i installed java 7

java -version 
java version "1.7.0_80"

is there problem with using another version of java that coder used another ? or is there any problem of using java 7 with old version of storm ?

Answers


There is no problems to use Java 7 with storm 0.8.2 as I done it. But stay away from zookeeper 3.3.3. Try zookeeper 3.3.5 or higher since the 3.3.3 caused storm workers to hang, crash or stop after 4-5 hours.

As for maven, Maven 3.3 will work fine to build jar compatible with storm.


Need Your Help

How to determine if PFFile is Video or Image?

image swift video parse-platform pffile

I'm creating an application in IO's with Parse and

Javascript TypeError: Array is undefined

javascript jquery arrays

to test some things in javascript I am building a small minesweeper.