Connection to Accumulo just hangs on initialization

I have Accumulo running in a VM. This Groovy script will connect just fine from within the VM, but outside of the VM it hangs at the first println statement.

String instance = "test"
String zkServers = "localhost:2181"
String principal = "root";
AuthenticationToken authToken = new PasswordToken("testing1234");

ZooKeeperInstance inst = new ZooKeeperInstance(instance, zkServers);
println "Attempting connection"
Connector conn = inst.getConnector(principal, authToken);
println "Connected!"

This is the listing of ports I have opened up in Vagrant:

config.vm.network "forwarded_port", guest: 2122, host: 2122
  config.vm.network "forwarded_port", guest: 2181, host: 2181
  config.vm.network "forwarded_port", guest: 2888, host: 2888
  config.vm.network "forwarded_port", guest: 3888, host: 3888
  config.vm.network "forwarded_port", guest: 4445, host: 4445
  config.vm.network "forwarded_port", guest: 4560, host: 4560
  config.vm.network "forwarded_port", guest: 6379, host: 6379
  config.vm.network "forwarded_port", guest: 8020, host: 8020
  config.vm.network "forwarded_port", guest: 8030, host: 8030
  config.vm.network "forwarded_port", guest: 8031, host: 8031
  config.vm.network "forwarded_port", guest: 8032, host: 8032
  config.vm.network "forwarded_port", guest: 8033, host: 8033
  config.vm.network "forwarded_port", guest: 8040, host: 8040
  config.vm.network "forwarded_port", guest: 8042, host: 8042
  config.vm.network "forwarded_port", guest: 8081, host: 8081
  config.vm.network "forwarded_port", guest: 8082, host: 8082
  config.vm.network "forwarded_port", guest: 8088, host: 8088
  config.vm.network "forwarded_port", guest: 9000, host: 9000
  config.vm.network "forwarded_port", guest: 9092, host: 9092
  config.vm.network "forwarded_port", guest: 9200, host: 9200
  config.vm.network "forwarded_port", guest: 9300, host: 9300
  config.vm.network "forwarded_port", guest: 9997, host: 9997
  config.vm.network "forwarded_port", guest: 9999, host: 9999
  #config.vm.network "forwarded_port", guest: 10001, host: 10001
  config.vm.network "forwarded_port", guest: 10002, host: 10002
  config.vm.network "forwarded_port", guest: 11224, host: 11224
  config.vm.network "forwarded_port", guest: 12234, host: 12234
  config.vm.network "forwarded_port", guest: 19888, host: 19888
  config.vm.network "forwarded_port", guest: 42424, host: 42424
  config.vm.network "forwarded_port", guest: 49707, host: 49707
  config.vm.network "forwarded_port", guest: 50010, host: 50010
  config.vm.network "forwarded_port", guest: 50020, host: 50020
  config.vm.network "forwarded_port", guest: 50070, host: 50070
  config.vm.network "forwarded_port", guest: 50075, host: 50075
  config.vm.network "forwarded_port", guest: 50090, host: 50090
  config.vm.network "forwarded_port", guest: 50091, host: 50091
  config.vm.network "forwarded_port", guest: 50095, host: 50095

Any ideas why it is not letting my connect? It just hangs and never even seems to time out.

Answers


I got this response from the mailing list and it cleared everything up:

Could be that the Accumulo services are only listening on localhost and not the "external" interface for your VM. To get a connector, that's a call to a TabletServer which run on 9997 by default (and you have open).

Do a netstat -nape | fgrep 9997 | fgrep LISTEN in your VM and see what interface the server is bound to. I'd venture a guess that you just need to put the FQDN for your VM in $ACCUMULO_CONF_DIR/slaves (and masters, monitor, gc, tracers, for completeness) instead of localhost.


Need Your Help

How to find image on whole screen?

ui-automation ranorex

Is it possible to click on an image, that is not located in a specific container element?

Libarchive Gem Not Working (RoR)

ruby-on-rails compression gem decompression

I'm trying to get libarchive working in my Rails app. Specifically, I need to unzip a file and re-compress its contents as a .CPGZ file. I believe Libarchive is my best bet for this.